WordPress introduserer automatisk oppdatering

med Ingen kommentarer

I dag ble det annonsert på WordPress offisielle utviklingsblogg at WordPress 3.7 vil komme med automatisk oppdatering innebygget. Det betyr at dersom det skulle oppdages sårbarheter i 3.7, og disse rettes i 3.7.1 eller 3.7.2, så vil alle installasjoner automatisk oppdatere seg til 3.7.1 eller 3.7.2 i løpet av ca 12 timer.

Det er en rekke installasjoner av WordPress «ute i det fri» som er satt opp og så nærmest forlatt av eieren. Eieren ser at siden er oppe, og er fornøyd, er kanskje innom for å legge ut en nyhet, men tør ikke røre oppdateringer, selv det er varsler om det. Grunnene kan være ren frykt for å endre på noe som helst slik at siden får feil eller problemer. De vil helst rådføre seg med en ekspert, noe som ofte ikke skjer. Og de har j satt opp «siden», den ser ut som den skal og som den gjorde, og alt er tilsynelatende i orden, så hvorfor ta sjanser på å gjøre noe man ikke forstår rekkevidden av?

Problemet er bare det at hvis en sårbarhet oppdages så er nettstedet ikke lenger trygt. Eieren risikerer at neste gang han besøker siden sin, så er den «hacked by …». Slik er det med all programvare, at sårbarheter kan finnes om man utsetter den for fantasifulle angrep beregnet nettopp på å avsløre slikt. Så lenge slike forblir en hemmelighet, så lenge kun den som oppdaget den vet om den, så er det ikke særlig trusel. Det er tross alt hundrevis av millioner av nettsider. Men straks slike sårbarheter er offentliggjort og beskrevet i detalj så er det fare å ferde. Da kan hvem som helst utnytte dem. Sårbarheter blir tilmed offentliggjort i beste mening, og det skjer etter at de er meldt inn til de som utvikler programvaren, og disse ha fått god tid til å rette feilen.

Så sårbarheter og rettelser av slike er en normal ting med all seriøs programvare, og vi kjenner det fra Windows og nettlesere, fra mobiltelefoner og app-er på disse. Men slike oppdateringer skje raskt og helst automatisk slik at ikke tusenvis og millionvis blir stående igjen uten rettelsen, for å så fall er de alle åpne for enhver som vil utnytte sårbarheten.

Det er derfor med stor glede å lese at WordPress 3.7 får slik oppdatering automatisert. Det er stort og viktig fremskritt for WordPress, og vil ytterligere forsterke plattformen som sikker, trygg og stabil.

Merk likevel at WordPress ikke automatisk vil oppdatere seg fra 3.7 eller 3.7.x til 3.8. Dette er hovedoppdateringer, og de må man fortsatt selv aktivt godkjenne, om man ikke har installert utvidelsen «Automatic Updater», en utvidelse som kan ta seg all oppgradering.

WordPress 3.7 er ventet sluppet medio oktober. Husk å oppgradere!

Legg inn en kommentar